Windows
For Windows
Android
For Android
Mac OS X
For Mac OS X
Linux
For Linux

#1 Re: Bugreports » HH reloaded - Login nicht mehr möglich » 2018-04-26 12:20:12

zyz wrote:

du muß dann nur die ip im bot entschprechend anpassen, also 127.0.0.1 durch die ip des Rechners ersetzten auf dem der proxy läuft.

Das würde funktionieren. Ich kann abern nur davon abraten einen HTTP-Proxy offen im Internet zu betreiben. Einfacher (und genauso gut) ist es das Proxy-Skript auf dem selben Rechner wie den Bot zu starten.

#2 Re: Bugreports » HH reloaded - Login nicht mehr möglich » 2018-04-22 10:47:15

blblbl wrote:

Auf eurem Bot habt ihr das auch aktiviert? oder noch nicht wegen der Proxyproblematik?
Ich denke es nutzen immer noch einige euren angebotenen "Server/Bot".

Der Server muss auf das richtige Update warten.

#3 Re: Bugreports » HH reloaded - Login nicht mehr möglich » 2018-04-22 00:32:37

Leider ist das doch eine größere Sache. Bis das Update mit HTTPS Unterstützung da ist, kann ich aber eine  Behelfslösung für lokale Bots anbieten.

Da der Bot ja kein HTTPS versteht, muss ein Proxy her, der den ganzen Verschlüsselungs-Kram übernimmt und für den Bot "übersetzt". So einen Proxy habe ich basierend auf NodeJS (https://nodejs.org/) gebaut.

var http = require('http'),
    https = require('https');

http.createServer(function (req, res) {
    let proxy_req = https.request({
        hostname: req.headers.host,
        method: req.method,
        path: req.url,
    }, (proxy_res) => {
        res.writeHead(proxy_res.statusCode, proxy_res.headers);
        proxy_res.on('data', (d) => {
            res.write(d);
        });
        proxy_res.on('end', (d) => {
            res.end();
        });
    });

    for (const key in req.headers) {
        proxy_req.setHeader(key, req.headers[key]);
    }
    proxy_req.flushHeaders();
    req.on('data', (d) => {
        proxy_req.write(d);
    });
    req.on('end', (d) => {
        proxy_req.end();
    });
}).listen(8000, "127.0.0.1");

Wenn NodeJS installiert ist, kann das Skript mittels node [dateiname] in der Konsole gestartet werden. Dann läuft ein Proxy auf  127.0.0.1 (localhost), Port 8000 (kann in der letzten Zeile angepasst werden). Wenn ihr 127.0.0.1:8000 im Bot als Proxy angebt, müsste der Bot wie normal laufen.

Der Nachteil dabei ist, dass sich mit dem Skript keine anderen Proxies mehr nutzen lassen. Wie das mit HTTPS und Proxies aussieht müssen wir aber sowieso noch klären.

#4 Makielskis Bot » Serverneustart und -Umzug » 2018-01-08 13:29:44

simon
Replies: 0

Hallo zusammen,

der Serverprovider hat zwecks Sicherheitspatches (Spectre, Meltdown) den Server neugestartet. Der Bot wird in Kürze wieder verfügbar sein.

Darüber hinaus werden wir im Laufe des Januar auf einen günstigeren (und schnelleren) Server wechseln. Dafür wird der Bot dann nochmal neugestartet werden.

Viele Grüße
Simon

#5 Re: Makielskis Bot » web-bot » 2017-07-31 07:41:17

Der Bot kommt gerade wieder online. Entschuldigt, dass es länger gedauert hat.

#6 Re: Makielskis Bot » Probleme in Malle » 2017-07-31 07:38:46

Kann ich nicht reproduzieren. Hat noch jemand das Problem? Habe es gerade mit unserem Test-Account im Vatikan ausprobiert.

#7 Re: Makielskis Bot » web-bot » 2017-05-22 10:03:16

Es gab einen Ausfall bei unserem Serverprovider. Der Bot startet jetzt neu.

#8 Re: Makielskis Bot » 20: element not a form or submit » 2016-08-18 15:03:30

Die Meldung bedeutet, dass sich der Bot nicht eingloggen konnte, weil er das Loginformular nicht gefunden hat. Bei mir geht das aber ohne Probleme.

Versuch es mal ohne Proxy. Solche Dinge liegen fast immer an fehlerhaften Proxies.

#9 Re: Makielskis Bot » GLIBCXX_3.4.18 not found » 2016-07-10 20:18:25

Der Bot wird gegen libstdc++ 6.0.19 aus der Raspberry Pi Toolchain (GCC 4.8.3) gelinkt. Das ist die älteste unterstützte Version.  Debian 8 (und damit Bananian 16.04) stellt 6.0.20 bereit. Von daher sollte es keine Probleme geben, wenn du das neueste Bananian daruf hast, denn neuere Versionen sind abwärtskompatibel.

#10 Re: Makielskis Bot » Linux Bot starten » 2016-04-06 10:39:32

Du hast die gleiche Frage doch schon mal gestellt. An der Installation hat sich seitdem nichts geändert.

http://bot.makielski.net/forum/viewtopi … 3664#p3664

Achte darauf die richtige Version runterzuladen. Vserver sind normalerweise keine ARM-Rechner, sondern x86_64. Du brauchst also wahrscheinlich die "Linux Version".

Debian Wheezy wird übrigens nicht mehr vom Debian Security Team betreut. Du solltest daher auf Debian 8 (Jessie) aktualisieren oder zumindest alle Updates installieren, wenn du den Long Term Support für Wheezy nutzen willst.

#11 Re: Bugreports » bot ist rot » 2016-02-10 11:40:48

Der Bot ist online.

Der Server musste über Nacht für ein wichtiges Sicherheitsupdate vom Hoster neu gestartet werden.

#12 Re: Bugreports » Windows-Bot läuft nicht » 2015-11-03 22:08:25

Ich konnte auf meiner Windows 7 Installation und einem durchgepatchten Windows XP keine Probleme feststellen.

Auf welchen Windows Versionen tritt das Problem auf?
Sind Firewalls/Antivieren-Programme installiert? Wenn ja: kannst du mal versuchen sie kurzzeitig abzuschalten?
Ist der "db" Ordner schon erstellt worden? Wenn ja: lösche ihn wider.

Board footer